Digital Ocean • Fast and Secure VPSCloud Computing Platform of Virtual Servers (Droplets), Object Storage (Spaces) and More



Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik


Konfigurasi IP Tunnel (IP-in-IP) Pada MikroTikCara Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik – Pada artikel kali ini saya akan membahas bagaimana Cara Mengkonfigurasikan IP Tunnel atau Tunnel IPIP (IP-in-IP) pada Router Mikrotik untuk menghubungkan host-host yang berada pada masing-masing router yang dipisahkan oleh jaringan publik dan menggunakan network yang berbeda. Berdasarkan kutipan dari situs MikroTik.ID, Protokol IPIP berkerja dengan cara mengenkapsulasi paket data dari satu IP ke IP (network yang berbeda) lain untuk membentuk network tunnel. Berbeda dengan EoIP yang hanya bisa digunakan untuk router yang sama – sama MikroTik, IPIP dapat berjalan hampir di semua jenis router selama router tersebut mendukung protokol IPIP.

 
Untuk menghubungkan host-host yang berbeda network ip dan berada dibawah masing-masing router yang terpisah oleh jaringan publik, ip tunnel/tunnel ipip bisa menjadi solusi dalam mengatasi hal ini karena disatu sisi akan menghemat biaya dalam pembangunan infrastruktur jaringan. IP Tunnel/Tunnel IPIP memungkinkan kita untuk menghubungkan network-network berbeda yang berada dibawah masing-masing router yang terpisah oleh jaringan publik, sedikit berbeda dengan EoIP Tunnel yang mana hanya bisa menghubungkan host-host yang menggunakan network yang sama.




 

Syarat dan Kondisi

Sebagai bahan praktek untuk mempelajari Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik, setidaknya kita harus mempunyai dua buah router mikrotik yang terpisah oleh jaringan publik, dan dibawah masing-masing router setidaknya ada satu host dan antara host yang berada dibawah Router A (R1) dengan host yang berada dibawah Router B (R2) harus menggunakan network ip yang berbeda.

Baca Juga :

Tutorial Mudah Cara Konfigurasi EoIP Tunnel MikroTik

Jika anda ingin mempraktekkan secara offline, anda harus menyiapkan tiga buah router dengan pola topologi kurang lebih seperti berikut ini :

 

Host A <-- Router A <-- Router Gateway --> Router B –> Host B

 
Berikut konfigurasi IP Address yang akan kita gunakan sebagai bahan praktek pada artikel ini :

 

Konfigurasi IP Tunnel Pada Router A (R1)

Disini saya asumsikan syarat diatas sudah terpenuhi dan selanjutkan kita langsung praktek, silahkan login ke Router A (R1) dengan menggunakan WinBox dan ikuti langkah-langkah dibawah ini.

  1. Membuat Interface IP Tunnel

    Untuk membuat interface IP Tunnel/Tunnel IPIP pada Router A (R1), jalankan perintah berikut di terminal mikrotik (sebelumnya silahkan sesuaikan bagian yang berwarna biru)

    /interface ipip add name=IP-Tunnel-R1 local-address=ip-publik-R1 remote-address=ip-publik-R2 !keepalive

  2. Memberi IP Address Pada Interface IP Tunnel

    Selanjutnya kita akan memberi ip address untuk interface ip tunnel yang sudah dibuat pada Router A (R1) yang bertujuan agar antara Router A (R1) bisa berkomunikasi dengan Router B (R2) melalui koneksi tunnel. Jalankan perintah berikut pada terminal mikrotik.

    /ip address add address=192.168.77.1/24 interface=IP-Tunnel-R1

 

Konfigurasi IP Tunnel Pada Router B (R2)

Selanjutnya kita akan melakukan konfigurasi IP Tunnel pada Router B (R2), caranya sama dengan yang dilakukan pada Router A (R1), tinggal menyesuaikan nama interface, local-address, remote-address serta ip address untuk interface IP Tunnel.

  1. Membuat Interface IP Tunnel

    Sesuaikan bagian yang berwarna biru :

    /interface ipip add name=IP-Tunnel-R2 local-address=ip-publik-R2 remote-address=ip-publik-R1 !keepalive

  2. Memberi IP Address Pada Interface IP Tunnel

    Selanjutnya beri ip address untuk interface ip tunnel pada Router B (R2) yang satu network dengan ip address interface ip tunnel pada Router A (R1). Disini kita akan menggunakan ip address 192.168.77.2/24

    /ip address add address=192.168.77.2/24 interface=IP-Tunnel-R2

Sampai disini antara Router A (R1) dengan Router B (R2) sudah terkoneksi melalui IP Tunnel/Tunnel IPIP, untuk pembuktian bisa anda lakukan tes ping dari Router A (R1) ke ip address interface IP Tunnel yang ada pada Router B (R2) ataupun sebaliknya.

Baca Juga :

Cara Setting OpenVPN di MikroTik (Client dan Server)

Konfigurasi IP Tunnel (IP-in-IP) Pada MikroTik - Tes Ping Antar Router

Lalu bagaimana caranya agar Host yang ada pada Router A (R1) bisa terhubung dengan Host yang ada pada Router B (R2) ?

Setelah selesai tahap-tahap diatas, koneksi ip tunnel hanya sebatas menghubungkan antar router, lalu bagaimana cara menghubungkan host pada Router A (R1) dengan host pada Router B (R2) ? Jawabannya sangat mudah, anda hanya perlu membuatkan satu buah statik routing pada masing-masing router.

Membuat Statik Routing Pada Router A (R1)

Seperti pada kondisi yang saya jelaskan diatas, host B menggunakan network ip 192.168.88.0/24 dan ip address untuk interface ip tunnel pada Router B (R2) adalah 192.168.77.2/24, maka untuk penambahan statik routingnya jalankan perintah berikut pada terminal mikrotik (silahkan sesuaikan jika anda menggunakan network ip yang berbeda)

/ip route add gateway=192.168.77.2 dst-address=192.168.88.0/24

Membuat Statik Routing Pada Router B (R2)

Selanjutnya buat juga statik routing pada Router B (R1), kondisi pada artikel ini host A menggunakan network ip 10.50.88.0/24 dan ip address untuk interface ip tunnel pada Router A (R1) adalah 192.168.77.1/24, untuk membuat statik routingnya pada Router B (R2) jalankan perintah berikut pada terminal mikrotik (silahkan sesuaikan jika anda menggunakan network ip yang berbeda)

/ip route add gateway=192.168.77.1 dst-address=10.50.88.0/24

Hasil Tes Ping, Test Traceroute dan Tes Akses Folder yang disharing oleh Host B dari Host A setelah penambahan statik routing pada masing-masing router :

Konfigurasi IP Tunnel (IP-in-IP) Pada MikroTik - Tes Ping dan Sharing Folder Antar Host

Untuk akses folder sharing pada gambar diatas, Port 135 – 135 TCP/UDP dalam kondisi tidak diblokir pada masing-masing router atau masing-masing host.

Setelah selesai menambahkan statik routing pada masing-masing Router A (R1) dan Router B (R2), seharusnya antara host A dengan host B sudah bisa saling berkomunikasi melalui koneksi IP Tunnel/Tunnel IPIP. Bisa anda lakukan tes ping dari host A ke host B ataupun sebaliknya, seperti contoh yang ada pada gambar diatas.

Jika dalam hal ini anda masih terkendala, coba periksa kembali langkah-langkah yang anda lakukan dan langkah-langkah yang saya jelaskan diatas harap dibaca dan dipahami dengan teliti.



Sekian dulu artikel kali ini dengan pembahasan mengenai Cara Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik, semoga bisa memberi manfaat dan menambah wawasan kita dalam membuat koneksi tunnel pada router mikrotik. Selamat mencoba dan selamat bereksperimen.

   

Leave a Comment

Be the First to Comment!

Notify of
avatar
wpDiscuz