Digital Ocean • Fast and Secure VPSCloud Computing Platform of Virtual Servers (Droplets), Object Storage (Spaces) and More



Cara Setting VPN SSTP Pada MikroTik (Client dan Server)


Cara Setting VPN SSTP Pada MikroTikCara Setting VPN SSTP Pada MikroTik – VPN Jenis SSTP atau Secure Socket Tunneling Protocol merupakan salah satu jenis service VPN di MikroTik yang berjalan dengan protokol TCP dengan port 443, seperti yang kita tahu port 443 ini adalah port default yang digunakan untuk koneksi yang berenkripsi. VPN Jenis SSTP ini jauh lebih aman dibanding VPN jenis PPTP ataupun L2TP, karena dengan konfigurasi yang tepat dan penggunaan Sertifikat SSL dalam negosiasi koneksi, keamanan koneksi antara klien dan server bisa lebih terjamin karena koneksi yang terbentu sudah dienkripsi atau disandikan.

Pada artikel yang terdahulu saya sudah membahas bagaimana Cara Setting VPN PPTP di MikroTik (Server dan Client), disini saya anggap kawan-kawan sudah paham dan bisa menerapkan sendiri peenggunaan VPN PPTP pada MikroTik. Pada artikel kali ini saya akan membahas tuntas Cara Setting VPN SSTP Pada MikroTik dengan menggunakan sertifikat SSL yang akan kita buat di mikrotik.




Baca Juga :

Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik

Syarat dan Kondisi

Disini saya asumsikan mikrotik anda sudah terkoneksi dengan baik ke internet dan bisa diakses melalui winbox, dan komputer atau laptop yang anda gunakan juga sudah terkoneksi ke internet melewati mikrotik. Pastikan juga trafik untuk protokol TCP dengan port 443 tidak terblokir oleh firewall, baik itu untuk trafik input ataupun forward.

Dan jika anda menggunakan 2 buah router mikrotik yang terpisah oleh 2 jaringan internet sebagai bahan praktek untuk SSTP Client dan SSTP Server, pastikan mikrotik anda bisa diakses dari luar jaringan , baik itu dengan menggunakan ip publik ataupun DDNS.

 

MikroTik Sebagai Secure SSTP Server

Untuk mengkonfigurasi mikrotik sebagai SSTP Server yang menggunakan sertifikat SSL, silahkan ikuti langkah-langkah berikut ini :

  • Membuat Address Pool Untuk Klien VPN SSTP, jika anda ingin menggunakan pool address dengan range yang berbeda silahkan anda sesuaikan pada baris perintah dibawah ini dan lanjutkan dengan mengcopy paste ke terminal mikrotik :

    /ip pool add name=pool_vpn_sstp ranges=172.16.100.100-172.16.100.254

  • Membuat Profile VPN SSTP, untuk membuat profile yang akan digunakan secara otomatis oleh klien VPN SSTP, jalankan perintah dibawah ini pada terminal mikrotik, profile ini juga akan digunakan saat kita mengaktifkan service VPN SSTP pada mikrotik yang bertindak sebagai Server VPN SSTP :

    /ppp profile
    add dns-server=172.16.100.1 local-address=172.16.100.1 name=profile_vpn_sstp remote-address=pool_vpn_sstp

  • Membuat Username dan Password untuk Klien VPN SSTP, jalankan perintah berikut ini pada terminal mikrotik untuk membuat username dan password untuk klien VPN SSTP, username dan passwordnya silahkan disesuaikan :

    /ppp secret
    add name=ppp1 password=abc1 profile=profile_vpn_sstp

  • Membuat Sertifikat SSL di MikroTik yang Bertindak sebagai SSTP Server
    Akses melalui winbox menu SYSTEM -> CERTIFICATE -> TANDA PLUS (+) , dan perhatikan gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step1-min

    Silahkan sesuaikan kolom isian pada bagian : Name, Country, State, Locality, Organization, Unit, dan Common Name. Untuk Common Name bisa diisi dengan IP Publik atau DDNS untuk mikrotik yang bertindak sebagai SSTP Server, disini saya akan menggunakan DDNS dari situs https://freedns.afraid.org/

    Setelah selesai pengisian form, klik tombol APPLY dan anda lanjutkan seperti gambar berikut ini :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step2-min

    Setelah konfigurasi sudah sesuai seperti gambar diatas, klik tombol APPLY dan anda lanjutkan dengan mengklik tombol EXPORT, bertujuan untuk mengeksport sertifikat yang sudah dibuat agar bisa diimport ke klien VPN SSTP, dalam hal ini kita akan menggunakan Windows7 sebagai klien VPN SSTP. Perhatikan gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step3-min

    Pastikan di File List sudah terdapat file sertifikat yang sudah diekspor dengan ekstensi .CRT , perhatikan gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step4-min

  •  

  • Mengaktifkan service VPN SSTP Pada MikroTik
    Selesai proses pembuatan dan pengeksporan sertifikat SSL mikrotik, sekarang kita aktifkan service VPN SSTP pada mikrotik dengan membuka menu PPP -> INTERFACE -> SSTP SERVER , kemudian perhatikan dan ikuti langkah-langkah seperti gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - enable service sstp-min
  •  

  • Mengimport Sertifikat SSL yang sudah dieksport ke Windows7
    Terlebih dahulu silahkan download atau simpan atau copy file sertifikat yang sudah diekspor di mikrotik (ada di File List MikroTik) ke komputer anda , dan selanjutnya kita akan import ke sistem windows7.

    Double click (klik 2x) pada file sertifikat yang sudah berada pada komputer anda lalu perhatikan urutan langkah yang ada pada gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step5-min
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step6-min
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step7-min

  •  

  • Membuat Interface VPN SSTP Client Pada Windows7
    Tiba saatnya untuk uji coba mengkoneksikan komputer anda (Windows7) dengan Server VPN SSTP yang ada pada MikroTik, untuk membuat interface VPN SSTP pada windows7 silahkan buka : CONTROL PANEL -> NETWORK SHARING CENTER , dan perhatikan gambar dibawah ini :

    # SETUP NEW CONNECTION OR NETWORK
    Membuat Koneksi VPN pada Windows 7 - step1-min

    # CONNECT TO A WORKPLACE
    Membuat Koneksi VPN pada Windows 7 - step2-min

    # USE MY INTERNET CONNECTION (VPN)
    Membuat Koneksi VPN pada Windows 7 - step3-min

    # ISIKAN IP SERVER VPN (IP MikroTik / DDNS), sesuaikan ip server vpn dengan kondisi ditempat anda, anda juga bisa menggunakan DDNS jika anda mempraktekkan pada jaringan publik. Pada tutorial ini saya menggunakan DDNS karena langsung mempraktekkan pada mikrotik yang berada pada jaringan publik.
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step8-min

    # ISIKAN USERNAME DAN PASSWORD (AKUN VPN), Sesuaikan Username dan Password VPN yang digunakan dengan Username dan Password VPN yang sudah anda buat pada mikrotik pada langkah sebelumnya.
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step9-min

    # KONEKSI VPN SIAP DIGUNAKAN
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step10-min

  •  

  • Setting Interface VPN pada Windows7
    Selanjutnya kita lakukan sedikit konfigurasi pada interface VPN yang sudah kita buat pada windows7 agar menggunakan protokol SSTP, perhatikan gambar :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step11-min
  •  

  • Tahap Uji Coba Koneksi VPN SSTP
    Setelah selesai langkah diatas silahkan anda test aktifkan (menghubungkan) interface VPN SSTP di komputer anda dan coba lakukan tes ping.
    Cara Setting VPN SSTP Pada MikroTik - SSTP Server - step12-min

 

MikroTik Sebagai Secure SSTP Client

Tahap berikut ini kita akan mencoba mengkonfigurasikan mikrotik sebagai klien dari VPN SSTP, untuk tahap ini anda harus mempunyai dua buah mikrotik yang mana masing-masing bertindak sebagai server VPN SSTP dan client VPN SSTP. Silahkan ikuti panduan berikut :

  • Ekspor sertifikat SSL pada server VPN SSTP beserta private key-nya
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step1-min

    Pada List File di mikrotik anda akan menemukan dua buah file yaitu : file sertifikat SSL dengan ekstensi .CRT dan file private key dengan ekstensi .KEY, silahkan disimpan ke komputer anda dan diupload ke mikrotik yang bertindak sebagai client VPN SSTP
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step2-min

  •  

  • Import File Sertifikat SSL dan Private Key ke MikroTik Client VPN SSTP
    Setelah File Sertifikat SSL dan Private Key diupload ke mikrotik client VPN SSTP, selanjutnya kita akan import kedua file tersebut agar bisa digunakan pada interface VPN SSTP di mikrotik yang bertindak sebagai client VPN SSTP.

    Akses mikrotik client VPN SSTP dengan winbox dan akses menu : SYSTEM -> CERTIFICATE -> IMPORT
    Pertama kita akan import file .CRT nya, kemudian ulang proses import untuk file .KEY nya, perhatikan dua buah gambar berikut :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step3-min
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step4-min

  •  

  • Buat Interface SSTP Client pada MikroTik Client
    Tahap terakhir adalah membuat interface SSTP Client pada mikrotik yang bertidak sebagai Client VPN SSTP, pada winbox akses menu PPP -> INTERFACE -> TANDA PLUS (+) dan pilih SSTP Client, kemudia konfigurasikan seperti gambar berikut ini :
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step5-min

    Untuk nama interface SSTP Client-nya silahkan set sesuai keinginan anda.

  • Mengaktifkan NAT Masquerade Untuk Interface VPN SSTP
    Copy paste-kan perintah berikut pada terminal :

    /ip firewall nat
    add comment=nat-vpn-sstp chain=srcnat out-interface=VPN-SSTP action=masquerade

    Sesuaikan tulisan yang berwarna biru, anda arahkan out-interface-nya ke interface SSTP Client pada mikrotik anda.

  • Tes trafik ICMP (Ping) ke DNS 8.8.8.8 di-route ke Interface VPN SSTP, sebagai bahan percobaan kita akan tes membuat satu buah routing statik untuk trafik dns 8.8.8.8 agar lewat ke interface VPN SSTP, jalankan perintah berikut di terminal mikrotik

    /ip route
    add comment=via-VPN-SSTP dst-address=8.8.8.8 gateway=VPN-SSTP

    Berikut ini contoh penampakan hasil dari langkah diatas pada tempat saya, hanya nama interface VPN-nya saja yang berbeda.
    Cara Setting VPN SSTP Pada MikroTik - SSTP Client - step6-min

  • Silahkan anda tes juga membelokkan trafik lain ke interface VPN SSTP yang sudah berstatus connected, seperti trafik games online dan lain-lain, silahkan dioprek.

Jika anda menggunakan 2 buah line internet, silahkan tambahkan satu statik routing lagi yang destination address-nya mengarah ke ip server VPN SSTP dan gatewaynya anda arahkan ke line internet yang ingin digunakan sebagai jemabatan penghubung ke server VPN SSTP. Ini bertujuan agar trafik masuk dan keluar ke server IP VPN SSTP bisa menggunakan line internet yang sama dan tidak terjadi perpindahan dan pertukaran gateway, jadi silahkan sesuaikan.

Baca Juga :

Tutorial Membuat VPN Server PPTP Pada Debian Jessie

Semua langkah-langkah diatas sudah saya uji coba terlebih dahulu sebelum artikel ini saya publish, jika seandainya anda mengalami kendala, mohon diperiksa langkah-langkah anda sesuai dengan yang saya arahkan diatas dan silahkan tinggalkan komentar jika ada pertanyaan. Dan Jika anda menemukan kesalahan penyampaian yang tidak terperhatikan oleh saya mohon tinggalkan komentar untuk saya koreksi.



Sekian dulu untuk artikel kali ini, saya sangat berharap sekali hal ini bisa memberi manfaat untuk orang banyak. Jangan lupa kunjungi terus TopSETTING.COM untuk mendapatkan artikel dan tutorial bermanfaat lainnya. Selamat mencoba dan selamat bereksperimen 🙂 .

   

Leave a Comment

4 Comments on "Cara Setting VPN SSTP Pada MikroTik (Client dan Server)"

Notify of
avatar
Sort By:   Newest | Oldest | Most Voted
ghober
Guest
ghober

mohon pencerahan. apakah klo ada 5 client kita harus buat 5 certificate juga ? atau hanya butuh 1 saja?

Member

Pada saat instalasi sertifikat, pilihan “local computer” pada “trusted root cartificate authorities” pada PC saya tidak ada.?

wpDiscuz