Digital Ocean • Fast and Secure VPSCloud Computing Platform of Virtual Servers (Droplets), Object Storage (Spaces) and More



Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik


Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik
Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik – Seperti judul artikel ini, Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik, merupakan optimasi lanjutan terhadap PHPMixBill agar bisa berinteraksi lebih baik dengan hotpsot mikrotik, khususnya integrasi dalam hal login page dan autentikasi login.

Pada Artikel sebelumnya saya sudah membahas Tutorial Install dan Setting PHPMixBill sebagai Billing Hotspot MikroTik dan Cara Modifikasi Design Print Voucher PHPMixBill, bagi yang ketinggalan silahkan baca-baca dulu tutorial sebelumnya agar lebih mudah memahami tujuan dan maksud dari artikel ini. Karena pada artikel kali ini saya mencoba berbagi beberapa script PHPMixBill yang sudah dimodifikasi agar terintegrasi ke login page hotspot mikrotik serta menjadikan kode voucher PHPMixBill sebagai media autentikasi login ke server hotspot mikrotik.




Baca Juga :

Download PHPMixBill Voucher Generator Terbaru

Sebelum saya menjelaskan lebih lanjut , ada baiknya saya jelaskan dulu pola dan cara kerja integrasi PHPMixBill dengan login page hotspot mikrotik setelah menerapkan isi dari artikel ini :

  1. Saat user hotspot terhubung ke SSID Hotspot, user hotspot akan diarahkan ke file login.html yang ada pada folder_template_hotspot_anda/
  2. Lalu user akan di redirect ke login page PHPMixBill yang sudah di modifikasi untuk melakukan aktivasi kode voucher
  3. Setelah user melakukan aktivasi kode voucher, secara otomatis user diarahkan ke login page hotspot, yaitu pada file folder_template_hotspot_anda/hotspot/login.html
  4. Selanjutnya user hotspot bisa login ke hotspot dengan menggunakan kode voucher yang telah diaktivasi sebagai media autentikasi, karena saat user melakukan aktivasi kode voucher, secara otomatis kode voucher tersebut di input oleh PHPMixBill menggunakan protokol API ke router hotspot sebagai username untuk login hotspot, dan password yang digunakan disini adalah password global, perhatikan gambar berikut :

    list-user-hotspot
  5. Jika user hotspot sudah pernah melakukan aktivasi dan kode vouchernya masih valid, user hotspot tinggal klik tombol HOTSPOT pada login page PHPMixBill yang akan mengarahkan ke login page hotspot mikrotik (lihat gambar diakhir artikel ini)
  6. Alur akses ke file folder_template_hotspot_anda/login.html dan file folder_template_hotspot_anda/hotspot/login.html sama persis dengan pola dan cara kerja eksternal login page hotspot mikrotik

Untuk langkah awal kita akan melakukan sedikit modifikasi pada template login hotspot mikrotik, silahkan anda sesuaikan dengan template yang anda gunakan.

Modifikasi Template Login Hotspot MikroTik

  • Buat sebuah folder dengan nama hotspot dalam folder template login hotspot mikrotik anda dan copykan file login.html,error.txt dan semua file atau folder CSS,IMG/IMAGE,JS anda kedalam folder hotspot yang sudah dibuat. Berikut contoh pada tempat saya :

    contoh-1
  • Lalu anda edit file login.html yang sudah berada pada folder_template_hotspot_anda/hotspot/, cari element input dengan type="username" dan type="password", perhatikan contoh pada file login.html milik saya :

    Yang akan kita rubah hanya kode yang ada pada line 6 dan line 7, sebelumnya silahkan sesuaikan dengan file yang anda gunakan. Perhatikan pada line 6 :

    <input name="username" ... type="text" .../> , anda rubah type="text" menjadi type="password"

    Lalu pada line 7, anda perhatikan element :

    <input name="password" ... type="password" .../>, anda rubah type="password" menjadi type="hidden" value="%kb^&_#!H5-04s15%"

    %kb^&_#!H5-04s15% adalah string acak yang akan menjadi global password sesuai dengan yang dideklarasikan pada file prepaid.php dan register.php, jika anda ingin merubah ini maka anda juga harus merubah value variabel $global_password yang ada pada file prepaid.php dan register.php

    Berhubung dengan banyaknya macam template login hotspot mikrotik, mungkin dibeberapa template akan ada perubahan-perubahan lain yang harus disesuaikan juga pada file template_login_hotspot_anda/hotspot/login.html, seperti penyesuaian lokasi link-link optional. Berikut contoh potongan isi file login.html saya sesudah disesuaikan sebagai patokan buat anda, anda perhatikan pada line 2 :

    Ingat ya, jika ada link pada file-file lain seperti file status.html, logout.html, dan file lainnya yang link tersebut mengarah ke file login.html, harus diarahkan ke file login.html yang berada dalam folder template_login_hotspot_anda/hotspot/.

    Selanjutnya edit file logout.html dan cari variabel $(link-login) lalu rubah sehingga menjadi hotspot/login.html

  • Langkah selanjutnya anda mundur satu folder dari folder_template_hotspot_anda/hotspot/ sehingga posisi anda berada pada folder_template_hotspot_anda/, dan anda buat sebuah file login.html baru, yang mana file ini yang akan meredirect user-user hotspot ke login page PHPMixBill untuk aktivasi voucher, kemudian PHPMixBill mengembalikan lagi ke template hotspot mikrotik untuk login dengan kode voucher yang sudah diaktivasi, berikut scriptnya dan anda sesuaikan bagian ip_server_phpmixbill pada line 6 dengan alamat server PHPMixBill milik anda :

    Kemudian anda tambahkan domain atau ip_server_phpmixbill anda ke Wallet Garden IP List hotspot mikrotik anda, atau tambahkan melalui perintah dibawah ini dan sesuaikan dst-address atau dst-host dengan domain atau ip server PHPMixBill anda :

    /ip hotspot wallet-garden ip add action=accept disabled=no dst-address=ip_server_phpmixbill
    atau
    /ip hotspot wallet-garden ip add action=accept disabled=no dst-host=domain_server_phpmixbill

Selanjutnya kita lakukan modifikasi pada PHPMixBill nya, silahkan anda siapkan alat tempurnya seperti WinSCP dan Notepad++, silahkanDownload WinSCP dari Website Resmi dan Download Notepad++ dari Website Resmi. Selanjutnya silahkan anda ikuti langkah-langkah berikut.

Baca Juga :

Cara Mengaktifkan Schedule User Expire pada PHPMixBill

Modifikasi Template Login Klien PHPMixBill

  • Terlebih dahulu anda anda download sebuah file melalui url ini : Download Style CSS PHPMixBill, setelah selesai didownload anda extrak dan upload folder “ styles” hasil ekstrak ke server PHPMixBill anda, tepatnya ada di root_folder_phpmixbill/ui/theme/default/, anda replace folder styles bawaan PHPMixBill
  • Selanjutnya buat sebuah file bernama hotspot.php pada folder root_folder_phpmixbill/system/controllers/, sebelum anda copy paste script dibawah ini ke file hotspot.php, anda sesuaikan nama domain_hotspot_anda yang ada pada line nomor 6 dengan kondisi di tempat anda

  • Selanjutnya anda replace semua isi file register.php yang ada pada root_folder_phpmixbill/system/controllers/
    dengan script yang ada pada link dibawah ini yang tujuannya untuk menjadikan kode voucher PHPMixBill sebagai autentikasi login hotspot mikrotik, dan auto input ke router hotspot saat kode voucher di-aktivasi :

    FILE REGISTER.PHP
    Download File register.php

  • Selesai langkah diatas lanjutkan dengan me-replace semua isi file prepaid.php dengan script yang ada pada link berikut ini yang memiliki tujuan yang sama dengan langkah diatas, hanya saja ini khusus buat user yang di tambahkan secara manual pada PHPMixBill.

    FILE PREPAID.PHP
    Download File prepaid.php

  • Masih dalam folder root_folder_phpmixbill/system/controllers/, anda lanjutkan dengan membuat sebuah file dengan nama bantuan.php dan copy paste script berikut sebagai isi dari file bantuan.php

  • Lalu anda lanjutkan dengan membuat sebuah file dengan nama hotspot.php dan copy paste script berikut, dan jangan lupa anda sesuaikan pada bagian domain_hotspot_anda :

  • Langkah selanjutnya anda masuk ke root_folder_phpmixbill/ui/theme/default/ dan buka file login.tpl lalu replace semua isinya dengan script dibawah ini, lalu anda replace domain_hotspot_anda yang ada pada line 60, sesuaikan dengan nama domain hotspot anda :

  • Selanjutnya masih dalam folder root_folder_phpmixbill/ui/theme/default/, anda buat sebuah file dengan nama bantuan.tpl yang isinya copy pastekan script dibawah ini dan ubah domain_hotspot_anda yang ada pada line 51 dengan nama domain hotspot anda :

  • Langkah terakhir, buka file admin.tpl yang ada pada root_folder_phpmixbill/ui/theme/default/, kemudian replace semua isinya dengan script dibawah ini :

Setelah selesai semua langkah-langkah diatas silah dicoba akses ulang login klien PHPMixBill anda, http://ip_server_phpmixbill/phpmixbill/index.php?_route=login, silahkan sesuaikan format urlnya dengan kondisi ditempat anda. Berikut contoh penampakan setelah menggunakan script diatas
Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik

Harus saya akui optimasi PHPMixBill ini untuk Integrasi Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik memanglah ribet, tapi dengan sedikit ketabahan dan kegigihan, bisa saya pastikan hasilnya penggunaan PHPMixBill sebagai Billing Hotspot MikroTik jadi lebih efisien seperti yang saya terapkan pada jaringan hotspot saya.



Pada artikel selanjutnya saya akan berbagi script cronjob untuk auto delete user expire dan auto delete voucher yang sudah digunakan serta cara mengaktifkan schedulenya pada router mikrotik. Mudah-mudah artikel kali ini bisa memberi manfaat buat para pengguna PHPMixBill, Selamat Mencoba dan Selamat Bereksperimen.

   

Leave a Comment

8 Comments on "Kode Voucher PHPMixBill Sebagai Username Hotspot MikroTik"

Notify of
avatar
Sort By:   Newest | Oldest | Most Voted
Ghofur
Guest
Ghofur

ada ga tutorial membuat form pendaftaran client hotspot yg terintegrasi dengan raspi+phpmixbill? kalau ada tolong di share dong !

danu
Guest
danu

gan klo generatenya gmna ???

M Ade TS
Guest

saya ganteng

Revi Ganteng
Guest

Saya Lebih GAnteng :p

wpDiscuz