Digital Ocean • Fast and Secure VPSCloud Computing Platform of Virtual Servers (Droplets), Object Storage (Spaces) and More



Tutorial Mudah Cara Konfigurasi EoIP Tunnel MikroTik


Tutorial Mudah Cara Konfigurasi EoIP Tunnel MikroTikTutorial Mudah Cara Konfigurasi EoIP Tunnel MikroTik – Ethernet over IP atau yang disingkat dengan EoIP merupakan sebuah protokol yang hanya dimiliki oleh OS MikroTik yang memungkinkan kita untuk bisa membangun tunnel (terowongan) jaringan ethernet diantara dua router diatas koneksi TCP/IP yang menggunakan protokol GRE (Generic Routing Encapsulation).

Dengan menggunakan EoIP Tunnel ini untuk menghubungkan dua router yang terpisah, maka semua host yang berada dibawah masing-masing router yang sudah terhubung melalui EoIP Tunnel bisa saling berkomunikasi bahkan dapat melakukan sharing serta penggunaan sumber daya lainnya antar jaringan. Komunikasi yang terjadi dalam EoIP Tunnel ini tidaklah menggunakan enkripsi untuk keamanan data, jadi sangat tidak direkomendasikan menerapkan EoIP untuk komunikasi data yang sensitif.




Kita anggaplah disini ada dua kantor yang saling terpisah di jaringan publik, kantor pusat dan kantor cabang. Disini kita akan coba mengkonfigurasikan EoIP dimasing-masing router yang ada pada kantor cabang dan kantor pusat agar host-host yang berada dibelakang masing-masing router tersebut bisa berkomunikasi.

Baca Juga :

Konfigurasi IP Tunnel/Tunnel IPIP (IP-in-IP) Pada MikroTik

Pada artikel ini saya akan coba mengimplementasikan EoIP Tunnel MikroTik pada dua buah router mikrotik yang terpisah oleh jaringan publik, dan masing-masing router memiliki ip statik (tidak menutup kemungkinan untuk menggunakan DDNS). Kira-kira topologinya berbentuk seperti gambar berikut ini :

Cara-Setting-Tunnel-EoIP-MikroTik

Syarat dan Kondisi

Harus ada dua mikrotik dan dua host agar kita bisa melakukan pengetesan komunikasi antar host melewati EoIP, dan masing-masing mikrotik haruslah sudah bisa diremote atau diakses dari luar jaringan jika anda mempraktekkan pada dua router yang terpisah oleh jaringan publik.

IP address yang digunakan jangan sampai ada yang sama antara host-host yang berada dibawah Router A dengan host-host yang berada dibawah Router B, karena jika EoIP Tunnel sudah terkoneksi, seolah-olah host-host tersebut akan berada pada jaringan yang sama dan tentunya akan terjadi konflik ip address.

Jika anda ingin mempraktekkan secara offline, anda harus menyiapkan tiga buah router dengan pola topologi kurang lebih seperti pola berikut ini :

 

Host A <-- Router A <-- Router Gateway --> Router B –> Host B

 

Konfigurasi EoIP Tunnel Pada Router A

Pertama kita konfigurasikan EoIP pada Router – A, silahkan langkah-langkah berikut :

  1. Buat Interface EoIP Tunnel Pada Router A

    /interface eoip add !keepalive name=eoip-router-A remote-address=IP-Address.router-B tunnel-id=1

    Sesuaikan tulisan yang berwarna biru dengan ip publik milik ROUTER-B

  2. Buat Interface Bridge Pada Router A

    /interface bridge add name=bridge-eoip-A

  3. Tambahkan Interface eoip-router-A ke dalam Bridge Port bridge-eoip-A

    /interface bridge port add interface=”eoip-router-A” bridge=”bridge-eoip-A”

  4. Tambahkan Interface Router-A yang terhubung ke Laptop/Host ke dalam Bridge Port bridge-eoip-A

    /interface bridge port add interface=”interface-local-A” bridge=”bridge-eoip-A”

    Sesuaikan tulisan yang berwarna biru dengan nama interface lokal yang ada pada ROUTER-A anda.

Setelah selesai langkah diatas maka konfigurasi EoIP Tunnel untuk ROUTER-A sudah selesai, selanjutnya kita akan konfigurasikan EoIP Tunnel untuk ROUTER-B agar antara host yang ada dibawah ROUTER-A bisa saling berkomunikasi dengan host yang ada dibawah ROUTER-B

Baca Juga :

Cara Setting OpenVPN di MikroTik (Client dan Server)

 

Konfigurasi EoIP Tunnel Pada Router B

Konfigurasi EoIP Tunnel pada ROUTER-B tidak jauh berbeda dengan konfigurasi yang sudah kita buat pada ROUTER-A, hanya berbeda di bagian remote-address saja dan nama interface agar mudah dibedakan, silahkan ikuti langkah-langkah berikut ini :

  1. Buat Interface EoIP Tunnel Pada Router B

    /interface eoip add !keepalive name=eoip-router-B remote-address=IP-Address.router-A tunnel-id=1

    Sesuaikan tulisan yang berwarna biru dengan ip publik milik ROUTER-A

  2. Buat Interface Bridge Pada Router B

    /interface bridge add name=bridge-eoip-B

  3. Tambahkan Interface eoip-router-B ke dalam Bridge Port bridge-eoip-B

    /interface bridge port add interface=”eoip-router-B” bridge=”bridge-eoip-B”

  4. Tambahkan Interface Router-B yang terhubung ke Laptop/Host ke dalam Bridge Port bridge-eoip-B

    /interface bridge port add interface=”interface-local-B” bridge=”bridge-eoip-B”

    Sesuaikan tulisan yang berwarna biru dengan nama interface lokal yang ada pada ROUTER-B anda.

Tutorial Cara Konfigurasi EoIP Tunnel MikroTik - Test Ping dan Tracert

Setelah selesai lanjutkan melakukan test ping dari laptop/host A ke laptop/host B, jika konfigurasi anda sudah sesuai dengan yang saya jelaskan diatas seharusnya test ping akan reply, gambar diatas contoh penampakan hasil test ping, tracert dan akses ke folder dokumen yang disharing oleh salah satu komputer yang ada pada jaringan ROUTER-B.

Jika anda masih gagal, coba periksa kembali langkah-langkah anda dengan teliti karena sebelum artikel ini saya publish, semua langkah-langkah diatas sudah lulus uji coba dan pastikan syarat serta kondisi sesuai dengan yang saya jelaskan sebelumnya.



Demikianlah artikel kali ini dengan pembahasan Tutorial Mudah Cara Konfigurasi EoIP Tunnel MikroTik, jika ada pertanyaan atau kesalahan dalam penulisan artikel yang tidak terperhatikan oleh saya, silahkan tinggalkan komentar. Selamat mencoba dan semoga bermanfaat.

   

Leave a Comment

Be the First to Comment!

Notify of
avatar
wpDiscuz